Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Port in Windows wird durch "non-exist" Prozess belegt. Wie beenden?

Mitglied: Cornitus

Cornitus (Level 1) - Jetzt verbinden

08.11.2018, aktualisiert 11:32 Uhr, 182 Aufrufe, 5 Kommentare

Hallo,

ich habe auf einem Hyper-V Server 2012 R2 vor einer ganzen Weile mal Veeam Backup and Replication installiert. Die Software haben wir dann aber wieder deinstalliert. Nun wollte ich erneut Veeam Backup and Replication installieren aber bei der Installation kommt die Meldung das die benötigten Ports bereits belegt sind.

"netstat -ano" zeigt mir die Prozess ID: 2272 für den Port. Dieser Prozess ist weder mit dem ProcessExplorer zu sehen noch mit "tasklist".
"netstat -b" zeigt mir nichts an zu dem Prozess.
TcpView zeigt den Prozess "non-existent" an. Killen oder Close Connection funktioniert nicht.

Bei google habe ich nichts hilfreiches gefunden. Hat jemand einen Tipp?



Vielen Dank und viel Grüße!
Mitglied: NetzwerkDude
08.11.2018 um 11:43 Uhr
PowerShell mit adminrechten starten, ID vom Prozess mit:
01.
Get-NetTCPConnection
finden, und mit
01.
Stop-Process -id <ID> 
killen

Falls es nicht hilft, mit Get-Process bzw. Win32_Process WMI mehr über den Process rausfinden - am ende des Tages muss er jemandem gehören
https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell. ...
https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell. ...
https://docs.microsoft.com/en-us/powershell/module/nettcpip/get-nettcpco ...
Bitte warten ..
Mitglied: SlainteMhath
08.11.2018 um 12:11 Uhr
Moin,

idR hilft ein Reboot des Servers.

lg,
Slainte
Bitte warten ..
Mitglied: Cornitus
08.11.2018, aktualisiert um 12:17 Uhr
Hallo,

vielen Dank für die schnelle Antwort! Das hilft aber leider nicht. Es existiert weder ein Prozess noch ein Dienst. Ich denke ich bin über die übliche beenden Strategie weit hinaus. Daher auch die Frage hier ;).

Get-WmiObject -Class Win32_Process | Where-Object {$_.ProcessId -eq '2272'}
Get-WmiObject -Class Win32_Service | Where-Object {$_.ProcessId -eq '2272'}



Grüße!
Bitte warten ..
Mitglied: Cornitus
08.11.2018, aktualisiert um 12:17 Uhr
Zitat von SlainteMhath:

Moin,

idR hilft ein Reboot des Servers.

lg,
Slainte

Huhu,

in der Regel vielleicht schon ;). Aber nicht hier. Gestern Abend durchgeführt. Danke dir!

Grüße!
Bitte warten ..
Mitglied: Cornitus
09.11.2018 um 12:22 Uhr
Hallo,

ich konnte das Problem nun lösen. Der "Bösewicht" war die Intel Active Systemkonsole. Diese hat einen Webserver installiert "lighttpd.exe" und dieser hat genau diese Ports belegt. Ich habe nach und nach alle Nicht Windows Programme über den Taskmanager beendet und mir danach nochmal die belegten Ports angeschaut. Bei beenden des lighttpd.exe wurde diese immer wieder neu gestartet aber jeweils mit einer anderen ProcessID.

Fakt ist das dies über den üblichen Weg nicht erkennbar war/ist. Ich habe zumindest keine Parameter gefunden die mir noch mehr Informationen ausgeben.

Wenn jemand einen Tipp hat mit dem ich dieses Problem hätte lösen können, ohne try and error (das bereits genannte funktioniert NICHT!), wäre ich darüber dennoch sehr dankbar.

Grüße und ein schönes Wochenende
Bitte warten ..
Ähnliche Inhalte
Windows 7

Wie kann ich das beenden eines Prozesses Protokollieren?

Frage von ScrollerWindows 77 Kommentare

Hallo, sporadisch beenden sich an einem unserer PCs Prozesse (Win 7 Prof). Im eventlog steht nichts dazu. Gut wäre ...

Windows Server

Software Prozesse über GPO beenden

gelöst Frage von dakoerryWindows Server7 Kommentare

Guten Tag kann mir einer helfen, möchte gerne alle PC´s in einer Server 2012 R2 Domain einen bestimmten Prozess ...

Batch & Shell

Remote Prozesse Beenden

gelöst Frage von HanutaBatch & Shell6 Kommentare

Hallo Zusammen, gibt es die Möglichkeit von Powershell mit Stop-Process z. B. den Firefox auch Remote zu beenden? Möchte ...

VB for Applications

Prozess Beenden mit VBA (Excel)

gelöst Frage von ritzmannVB for Applications2 Kommentare

Hallo zusammen Drehe momentan am Rad, da ich nicht mehr weiter weiss. Erhoffe mir durch euch eine Lösung zu ...

Neue Wissensbeiträge
Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 12 StundenUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 16 StundenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 3 TagenSonstige Systeme6 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 3 TagenDatenschutz5 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Heiß diskutierte Inhalte
Windows 10
Programm unter Windows 10 automatisch mit administrativen Rechten starten
Frage von GrafmulderWindows 1018 Kommentare

Hallo zusammen! Zur Situation: Ich benutze Windows 10 Pro für Workstations (Build 1803) mit zwei Konten. Einem Administratorkonto und ...

LAN, WAN, Wireless
Empfehlung Powerline Adapter
Frage von AgilolfingerLAN, WAN, Wireless16 Kommentare

Hallo Zusammen, ich brauche eine Empfehlung von euch. Ich möchte in einem privaten Haushalt eine Powerline Lösung einrichten. Allerdings ...

Vmware
Gebrauchten ESXi- Server verkaufen: Festplatten DSGVO-konform löschen?
Frage von l.scheperVmware14 Kommentare

Hallo, wir möchten einen gebrauchten FUJITSU Server verkaufen. Auf dieser Maschine ist noch ein installiertes ESXi 5.1 und ne ...

CPU, RAM, Mainboards
RAM - gleiche Nummer dennoch unterschiedlich
gelöst Frage von HenereCPU, RAM, Mainboards9 Kommentare

Servus zusammen, möchte meinem Server weitere 64GB RAM spendieren. Nun hatte ich die gleichen Module bestellt, wie ich schon ...